Just another IT site ※IT系の記事は当方環境での実施内容となるため実施する場合は自己責任でお願いいたします。At Your Own Risk!! TURN BACK WHILE YOU CAN
PR

zabbix ERROR: Both parameters “DBPort” and “DBSocket” are defined. Either one of them can be defined, or neither.

※IT系の記事は当方環境での実施内容となるため実施する場合は自己責任でお願いいたします。スクリプトはAI生成のものも多いのでコピー&ペーストの際は文字コードに注意ください!

ERROR: Both parameters “DBPort” and “DBSocket” are defined. Either one of them can be defined, or neither.

エラー: パラメータ「DBPort」と「DBSocket」の両方が定義されています。どちらか一方を定義するか、どちらも定義しないでください。

zabbixを7.0.14に上げたところ、zabbix-serverの起動に失敗。
journalctl -xeu zabbix-server.service

Jun 19 00:58:06 XXXXXX zabbix_server[2080]: zabbix_server [2080]: ERROR: Both parameters "DBPort" and "DBSocket" are defined. Either one of them can be defined, or neither.
Jun 19 00:58:06 XXXXXX systemd[1]: zabbix-server.service: Control process exited, code=exited, status=1/FAILURE

エラーに書かれている通り、

zabbix_server.conf で

#DBPort=3306

or

#DBSocket=/var/lib/mysql/mysql.sock

もしくは、両方をコメントとすることで、取り合えず起動した。

DBがらみのエラーとなっているように、この事象はzabbix-serverでのみ発生、zabbix-agent2は7.0.14に上げても問題なく起動。

タイトルとURLをコピーしました