Just another IT site ※IT系の記事は当方環境での実施内容となるため実施する場合は自己責任でお願いいたします。At Your Own Risk!! TURN BACK WHILE YOU CAN
PR

database /etc/postfix/XXXX.db is older than source file /etc/postfix/XXXX

※IT系の記事は当方環境での実施内容となるため実施する場合は自己責任でお願いいたします。スクリプトはAI生成のものも多いのでコピー&ペーストの際は文字コードに注意ください!

postfixでいつの間にか

database /etc/postfix/XXXX.db is older than source file /etc/postfix/XXXX

というエラーが表示されていた。

mailqも滞留、これが原因でメール送信が止まっている?確かに両ファイルのタイムスタンプにだいぶ差があったが、いつもソースファイル編集したら、すぐにpostmapしているので、普通だったらそのような差異が出るはずもなく。取り合えず

postmap XXXX
systemctrl restart postfix

で復旧

調べたところ、Postfixのアップデートにより、/etc/postfix/xxxx.db ファイルが上書きされることがあるらしい?

「warning: database /etc/postfix/virtual.db is older than source file /etc/postfix/virtual」 ワーニングがログに表示される | iPentec

[Postfix] 知らなかった!「virtual.db」のデコード方法 : 元うなぎ屋 (snickerjp.blogspot.com)

⇒dbファイルをデコードする「db_dump」コマンドのことは初めて知った。

タイトルとURLをコピーしました